Back to overview
Resolved
Planned Power Outage
Apr 28, 2026 at 11:00pm UTC
–
Apr 30, 2026 at 12:52pm UTC
Affected services
nathancole.org
Resolved
Apr 30, 2026 at 12:52pm UTC
Maintenance ended
Affected services
Updated
Apr 30, 2026 at 12:52pm UTC
Power is restored and the website is back online.
Affected services
Created
Apr 28, 2026 at 11:00pm UTC
There will be a planned power outage during which time the website will be offline. The website will go offline earlier than this to prevent data loss.
Affected services