Back to overview
Downtime
nathancole.org is down (power outage)
Oct 03 at 04:29pm BST
Affected services
nathancole.org
Resolved
Oct 03 at 07:25pm BST
nathancole.org recovered. Power has been restored and the webserver manually restarted.
Affected services
Created
Oct 03 at 04:29pm BST
nathancole.org went down. A power outage resulted in the webserver going offline.
Affected services