Back to overview
Downtime
nathancole.org is down (power outage)
Jun 10 at 12:49pm BST
Affected services
nathancole.org
Resolved
Jun 10 at 12:53pm BST
nathancole.org recovered. Power is restored and the webserver is back online.
Affected services
Created
Jun 10 at 12:49pm BST
nathancole.org went down. A power outage caused the webserver to go offline.
Affected services